directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "RakeshAcharya (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSERVER-1943) Apache DS 2.0.0-M10 Replication Doesnt work
Date Fri, 20 Dec 2013 18:46:10 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-1943?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13854408#comment-13854408
] 

RakeshAcharya commented on DIRSERVER-1943:
------------------------------------------

Thanks for your response 

In the release notes of M10 I see an entry "DIRSERVER-1704 - Inconistency in Master-Slave
Replication" so it means Master-Slave Replication should be working as needed. Correct me
if my understanding is am wrong.

But in my case I clearly mentioned the problem I am facing , now I need your help to enlighten
me if I am missing some configuration/step as a reason Master-Slave is not working in my case
? or Its a Bug in the product which is addressed in other product releases if so I need a
release in which replication is thoroughly tested(master-master/master-Slave) and working.

Appreciate your assistance.


> Apache DS 2.0.0-M10 Replication Doesnt work
> -------------------------------------------
>
>                 Key: DIRSERVER-1943
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1943
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: ldap
>    Affects Versions: 2.0.0-M10
>         Environment: Production
>            Reporter: RakeshAcharya
>              Labels: features, performance
>
> Trying to set up Master-Matser  and Master-Slave replication in apacheDS 2.0.0-M10 but
the results are not conistsent , it works and fails sometime.
> Followed below link to configure the same.
> http://joacim.breiler.com/apacheds/ch08s02.html
> Can you please let me know what am I missing? We have a live date and needs this replication
FIXED ASAP.
> Errors: (some of the error)
> INFO   | jvm 1    | 2013/12/19 17:50:48 | [17:50:48] ERROR [org.apache.directory.server.ldap.replication.consumer.ReplicationConsumerImpl]
- ERR_251_PARENT_NOT_FOUND Parent ou=users,dc=fico,dc=com not found
> INFO   | jvm 1    | 2013/12/19 17:50:48 | org.apache.directory.api.ldap.model.exception.LdapNoSuchObjectException:
ERR_251_PARENT_NOT_FOUND Parent ou=users,dc=fico,dc=com not found
> INFO   | jvm 1    | 2013/12/19 17:50:48 |       at org.apache.directory.server.core.exception.ExceptionInterceptor.add(ExceptionInterceptor.java:164)



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message