directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Kanter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSHARED-134) Missing artifact org.apache.directory.jdbm:apacheds-jdbm2:bundle:2.0.0-M1 when depending on apacheds-server-jndi
Date Thu, 14 Nov 2013 01:45:21 GMT

    [ https://issues.apache.org/jira/browse/DIRSHARED-134?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13822082#comment-13822082
] 

Robert Kanter commented on DIRSHARED-134:
-----------------------------------------

I know this was last updated a long time ago, but I'm having the same issue but with the {{apacheds-jdbm1}}
artifact when I try to include a dependency on either of these:
{code:xml}
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-jdbm-partition</artifactId>
      <version>2.0.0-M15</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-protocol-ldap</artifactId>
      <version>2.0.0-M15</version>
      <scope>compile</scope>
    </dependency>
{code}
Maven is unable to find {{org.apache.directory.jdbm:apacheds-jdbm1:bundle:2.0.0-M2}}

I tried adding the maven-bundle-plugin like in the first comment, but that didn't make a difference.
 I went and looked in the repository itself, and didn't see any kind of "bundle" thing.  

In the meantime, I found a workaround [here|https://bitbucket.org/resah/embedded-apacheds/commits/85ff4716f58f4db8418a0a2ff965e7a8db9f5a0e#chg-pom.xml]
where you basically exclude the {{apaches-jdbm1}} dependency from anything that tries to pull
it in, and then explicitly add it as a dependency, but using version {{2.0.0-M3-SNAPSHOT}}
instead of {{2.0.0-M2}}, which doesn't use a bundle type:
{code:xml}
    <dependency>
        <groupId>org.apache.directory.jdbm</groupId>
        <artifactId>apacheds-jdbm1</artifactId>
        <version>2.0.0-M3-SNAPSHOT</version>
      <scope>compile</scope>
    </dependency>
{code}
While this seems to be working as far as I can tell, it would be better if I didn't have to
mix versions.  

Can you check that the artifact is being properly published?

> Missing artifact org.apache.directory.jdbm:apacheds-jdbm2:bundle:2.0.0-M1 when depending
on apacheds-server-jndi
> ----------------------------------------------------------------------------------------------------------------
>
>                 Key: DIRSHARED-134
>                 URL: https://issues.apache.org/jira/browse/DIRSHARED-134
>             Project: Directory Shared (Please use DIRAPI instead)
>          Issue Type: Bug
>    Affects Versions: 1.0.0-M11
>            Reporter: Hendy Irawan
>            Assignee: Pierre-Arnaud Marcelot
>             Fix For: 1.0.0-M12
>
>
> Missing artifact org.apache.directory.jdbm:apacheds-jdbm2:bundle:2.0.0-M1 when depending
on :
>     <dependency>
>       <groupId>org.apache.directory.server</groupId>
>       <artifactId>apacheds-server-jndi</artifactId>
>       <version>2.0.0-M6</version>
>     </dependency>
> It should transitively depend on a "jar" type, not a bundle.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message