directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Knecht <fel...@apache.org>
Subject Re: [VOTE] Release of ApacheDS 2.0.0-M15
Date Thu, 15 Aug 2013 11:00:43 GMT
Building Mavibot using Java 6 (MAVIBOT-7) and using this mavibot as 
dependency ApacheDS also builds fine using Java 6.

Index: mavibot-partition/pom.xml
===================================================================
--- mavibot-partition/pom.xml   (revision 1514230)
+++ mavibot-partition/pom.xml   (working copy)
@@ -35,7 +35,7 @@
      <dependency>
        <groupId>org.apache.directory.mavibot</groupId>
        <artifactId>mavibot</artifactId>
-      <version>1.0.0-M1</version>
+      <version>1.0.0-M2-SNAPSHOT</version>
      </dependency>

Regards
Felix


On 08/15/2013 10:08 AM, Emmanuel Lécharny wrote:
> Le 8/15/13 7:39 AM, Felix Knecht a écrit :
>> As Kiran already mentioned, it builds only with JDK 1.7. Could it be
>> that Mavibot was build using JDK 1.7?
>>
>> Running
>> org.apache.directory.server.core.partition.impl.btree.mavibot.MavibotRdnIndexTest
>> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.034
>> sec <<< FAILURE! - in
>> org.apache.directory.server.core.partition.impl.btree.mavibot.MavibotRdnIndexTest
>> initializationError(org.apache.directory.server.core.partition.impl.btree.mavibot.MavibotRdnIndexTest)
>>   Time elapsed: 0.008 sec  <<< ERROR!
>> java.lang.UnsupportedClassVersionError:
>> org/apache/directory/mavibot/btree/RecordManager : Unsupported
>> major.minor version 51.0
>
> Yes, that's right, Maibot requires Java 7.
>
> I think we should make Mavibot build with Java 6, there is nothing Java
> 7 specific in it. I will create a JIRA for that.
>
>
>>
>> [X] +1 : release ApacheDS 2.0.0-M15
>>
>> Regards
>> Felix
>
>


Mime
View raw message