directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-915) Attribute values of syntac 1.3.6.1.4.1.1466.115.121.1.5 (binary) are displayed inconsistently
Date Fri, 14 Jun 2013 12:55:20 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-915?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13683323#comment-13683323
] 

Pierre-Arnaud Marcelot commented on DIRSTUDIO-915:
--------------------------------------------------

Hi Lothar,

I did a few other tests on my colleague's Edirectory (a 8.8 SP6 version) and still haven't
been able to reproduce the issue (even with the inetOrgPerson thing).

I had a look in the code and I can now explain why sometimes it would write "NULL". That's
because the received value is a "null" java object. But I still don't understand why this
object would be null since a value is showing in Gawor LDAP Browser/Editor.

In the end, we get three different displays for attributes that all share the same "Binary"
syntax:
- the default display "Binary data (xxx bytes)", which is what is expected since the attribute
is binary.
- the "NULL" display which is due to the fact that the editor receives a "null" java object,
which is very weird.
- the "complete string" display, that displays the text contained in the attribute, which
shouldn't happen since the attribute is "Binary". That part is really really weird.

Is there any way I could access the machine to debug the issue? (I imagine it's complicated)

In any case, here are a few other steps you could do to help me find out what is going on:

1°/ Could you verify in the schema browser that all the DirXML-xxxxxxx attribute types are
present and their syntax is "Binary" ?
http://cl.ly/PfTL

2°/ Could you deactivate the "decorated values" ( It's in the "triangle icon" at the top
right of the editor, then uncheck "Show Decorated Values") and make me a screenshot of then
editor ?
http://cl.ly/Pdyi

3°/ Just in case, restore the Binary Attributes default preferences in the corresponding
preference page, "Apache Directory Studio" > "LDAP Browser" > "Attributes" > "Binary
Attributes" and see if it changes anything.
http://cl.ly/Pev8

Thanks!



                
> Attribute values of syntac 1.3.6.1.4.1.1466.115.121.1.5 (binary) are displayed inconsistently
> ---------------------------------------------------------------------------------------------
>
>                 Key: DIRSTUDIO-915
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-915
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-ldapbrowser
>    Affects Versions: 2.0.0-M6 (2.0.0.v20130308)
>         Environment: Apache DS 2.0.0M6 on Win7-64 against Edirectory 8.8.7
>            Reporter: Lothar Haeger
>         Attachments: screenshot-1.jpg
>
>
> Attribute values of binary syntax OID 1.3.6.1.4.1.1466.115.121.1.5 are displayed inconsistently
and partly wrong. Those attributes contain base 64 encoded text and some of them are displayed
as
> - editable (inline + dialog) text
> - "Binary Data (xxx Bytes)"
> - NULL
> See attached screenshot for an example of Apache DS vs. Gawor LDAP Browser/Editor displayoing
the same object.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message