directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: [Result] [VOTE] Release of LDAP API 1.0.0-M18
Date Wed, 26 Jun 2013 10:09:36 GMT
For your info, there might be a small issue on the OSGI part of this release.

I'm getting a weird error in Eclipse when integrating the latest trunk (and version 1.0.0-M18)
with Apache Directory Studio.
The Manifest file for the LDAP Schema project seems a little buggy.
I haven't quite figure out what exactly yet, but it related to "Import-Package" and "Export-Package"
instructions being computed by the "maven-bundle-plugin".

This Maven plugin was upgraded to version 2.4.0 just before the release and it seems to be
the cause.
I'm not quite sure that's really a bug on this version of the plugin, it's probably some tuning
we need to do in the OSGI instructions in the pom.xml file.
I don't have the good formula yet.

Anyways, in the meantime and, to be able to release Apache Directory Studio later this afternoon,
I'll move back to version 2.3.7 (which works flawlessly) in the "project" pom, and also release
a fixed version of the LDAP API: 1.0.0-M19 (including fixes from Emmanuel as well).

Regards,
Pierre-Arnaud

On 25 juin 2013, at 11:25, Emmanuel L├ęcharny <elecharny@gmail.com> wrote:

> Hi,
> 
> I close the vote with 5 binding +1 :
> Felix
> Kiran
> Pierre-Arnaud
> Stefan
> and me
> 
> I'll prepare the announcement.
> 
> Thanks guys !
> 
> -- 
> Regards,
> Cordialement,
> Emmanuel L├ęcharny
> www.iktek.com 
> 


Mime
View raw message