directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lécharny <elecha...@gmail.com>
Subject Re: ApacheDS and Java 6 build pb
Date Sun, 19 May 2013 16:15:23 GMT
Le 5/19/13 4:04 PM, Kiran Ayyagari a écrit :
> On Sun, May 19, 2013 at 6:46 PM, Emmanuel Lécharny <elecharny@gmail.com>wrote:
>
>> Le 5/19/13 2:15 PM, Emmanuel Lécharny a écrit :
>>> Le 5/19/13 9:35 AM, Emmanuel Lécharny a écrit :
>>>> Hi guys,
>>>>
>>>> yesterday, I played with the pom.xml file to tell maven to build the
>>>> project using a Java 6 compatibility, instead of Java 5.
>>>>
>>>> I get some error in SaslBindIT. I think we have some incompatiblity with
>>>> a Java 6 built server... Is it just me ?
>>>>
>>> I can confirm that if I switch to JDK 1.6 compatibility on the project's
>>> pom, the build breaks...
>>>
>> Well, forget about this message. I was running the buld with -DskipTests.
>>
>> I have a failure on SaslBindIT test (server-integ) :
>>
>> Running org.apache.directory.server.operations.bind.SaslBindIT
>> javax.security.sasl.SaslException: GSS initiate failed [Caused by
>> GSSException: No valid credentials provided (Mechanism level: Server not
>> found in Kerberos database (7) - Server not found in Kerberos database)]
>>     at
>>
>> com.sun.security.sasl.gsskerb.GssKrb5Client.evaluateChallenge(GssKrb5Client.java:212)
>>     at
>>
>> org.apache.directory.ldap.client.api.LdapNetworkConnection.bindSasl(LdapNetworkConnection.java:3807)
>>     at
>>
>> org.apache.directory.ldap.client.api.LdapNetworkConnection.access$200(LdapNetworkConnection.java:178)
>>     at
>>
>> org.apache.directory.ldap.client.api.LdapNetworkConnection$2.run(LdapNetworkConnection.java:1529)
>>     at java.security.AccessController.doPrivileged(Native Method)
>>     at javax.security.auth.Subject.doAs(Subject.java:415)
>>     at
>>
>> org.apache.directory.ldap.client.api.LdapNetworkConnection.bindAsync(LdapNetworkConnection.java:1525)
>>     at
>>
>> org.apache.directory.ldap.client.api.LdapNetworkConnection.bind(LdapNetworkConnection.java:1427)
>>     at
>>
>> org.apache.directory.server.operations.bind.SaslBindIT.testSaslGssApiBind(SaslBindIT.java:519)
>>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>     at
>>
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>>     at
>>
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>>     at java.lang.reflect.Method.invoke(Method.java:601)
>>     at
>>
>> org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
>>     at
>>
>> org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
>>     at
>>
>> org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
>>     at
>>
>> org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
>>     at
>>
>> org.apache.directory.junit.tools.MultiThreadedMultiInvoker$1$1.run(MultiThreadedMultiInvoker.java:160)
>>     at
>>
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
>>     at
>>
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
>>     at java.lang.Thread.run(Thread.java:722)
>> Caused by: GSSException: No valid credentials provided (Mechanism level:
>> Server not found in Kerberos database (7) - Server not found in Kerberos
>> database)
>>     at
>> sun.security.jgss.krb5.Krb5Context.initSecContext(Krb5Context.java:710)
>>     at
>> sun.security.jgss.GSSContextImpl.initSecContext(GSSContextImpl.java:248)
>>     at
>> sun.security.jgss.GSSContextImpl.initSecContext(GSSContextImpl.java:179)
>>     at
>>
>> com.sun.security.sasl.gsskerb.GssKrb5Client.evaluateChallenge(GssKrb5Client.java:193)
>>     ... 20 more
>> Caused by: KrbException: Server not found in Kerberos database (7) -
>> Server not found in Kerberos database
>>     at sun.security.krb5.KrbTgsRep.<init>(KrbTgsRep.java:73)
>>     at sun.security.krb5.KrbTgsReq.getReply(KrbTgsReq.java:192)
>>     at sun.security.krb5.KrbTgsReq.sendAndGetCreds(KrbTgsReq.java:203)
>>     at
>>
>> sun.security.krb5.internal.CredentialsUtil.serviceCreds(CredentialsUtil.java:311)
>>     at
>>
>> sun.security.krb5.internal.CredentialsUtil.acquireServiceCreds(CredentialsUtil.java:115)
>>     at
>> sun.security.krb5.Credentials.acquireServiceCreds(Credentials.java:442)
>>     at
>> sun.security.jgss.krb5.Krb5Context.initSecContext(Krb5Context.java:641)
>>     ... 23 more
>> Caused by: KrbException: Identifier doesn't match expected value (906)
>>     at sun.security.krb5.internal.KDCRep.init(KDCRep.java:143)
>>     at sun.security.krb5.internal.TGSRep.init(TGSRep.java:66)
>>     at sun.security.krb5.internal.TGSRep.<init>(TGSRep.java:61)
>>     at sun.security.krb5.KrbTgsRep.<init>(KrbTgsRep.java:55)
>>     ... 29 more
>> Tests run: 17, Failures: 0, Errors: 1, Skipped: 4, Time elapsed: 15.545
>> sec <<< FAILURE!
>>
>>
>> Is anyone have the same failure, when running mvn clean install on trunk ?
>>
>> maven-compiler-plugin in apacheds/pom.xml is already targeted to 1.6
> but I have also changed the same plugin present in project/pom.xml to 1.6
> and didn't encounter this error
> otoh, I just ran this test alone using mvn test -Dtest=SaslBindIT
> you error could be an 'on Apple only' thing?

I have updated my JVM recently, and I suspect that it has some impact on
MacOSX...


-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com 


Mime
View raw message