directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Gamache (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (DIRSTUDIO-899) Unable to install Studio using the update site: "Missing requirement: ApacheDS Core 2.0.0.M11"
Date Fri, 05 Apr 2013 12:52:15 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-899?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13623593#comment-13623593
] 

Joe Gamache edited comment on DIRSTUDIO-899 at 4/5/13 12:50 PM:
----------------------------------------------------------------

Thanks for looking at this so quickly, but

If you take a clean install of the latest STS (and I assume Eclipse, but have not verified),
and add YOUR update site.  Then try to add the ApacheDS server, you get this error.  So there
must be a dependency in there on your end someplace!

---

Ok - I was wrong!

If you go here: http://directory.apache.org/studio/installation-in-eclipse.html

the update site is for 1.x, but that doesn't work at all.  If you change it to 2.x, then it
works and just adding the browser works, but if you add both server and browser (as I suspect
is most common), it gives the dependency error...

                
      was (Author: jgamache):
    Thanks for looking at this so quickly, but

If you take a clean install of the latest STS (and I assume Eclipse, but have not verified),
and add YOUR update site.  Then try to add the ApacheDS server, you get this error.  So there
must be a dependency in there on your end someplace!


                  
> Unable to install Studio using the update site: "Missing requirement: ApacheDS Core 2.0.0.M11"
> ----------------------------------------------------------------------------------------------
>
>                 Key: DIRSTUDIO-899
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-899
>             Project: Directory Studio
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M6
>            Reporter: Pierre-Arnaud Marcelot
>            Assignee: Pierre-Arnaud Marcelot
>            Priority: Blocker
>             Fix For: 2.0.0-M7
>
>
> This problem was reported on IRC.
> It seems like the ApacheDS Core module has a lot of imports on interceptors modules and
those modules are not part of the distribution.
> Here's the log from the user:
> !MESSAGE Missing requirement: ApacheDS Core 2.0.0.M11 (org.apache.directory.server.core
2.0.0.M11) requires 'package org.apache.directory.server.core.admin [2.0.0,3.0.0)' but it
could not be found

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message