directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSERVER-1790) When we restart the server, some user index are lost
Date Tue, 15 Jan 2013 15:06:12 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-1790?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13553866#comment-13553866
] 

Emmanuel Lecharny commented on DIRSERVER-1790:
----------------------------------------------

Ok, I confirm that the index is *not* correctly initialized. It seems to be available, but
we don't read it at startup, so we don't have any clue about the number of elements it contains,
so we default to 0, which leads the search engine to do a full scan.

I have to fix that now.
                
> When we restart the server, some user index are lost
> ----------------------------------------------------
>
>                 Key: DIRSERVER-1790
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1790
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M9
>            Reporter: Emmanuel Lecharny
>            Assignee: Emmanuel Lecharny
>            Priority: Blocker
>             Fix For: 2.0.0-M10
>
>
> Indexes are not anymore used when the server is restarted. The index was available when
the server was started the first time, then after a restart, even if the index exists on disk,
it's not anymore used by the server, causing a full scan to be done.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message