directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: [Vote] Release of ApacheDS (2.0.0-M9)
Date Sun, 23 Dec 2012 08:11:57 GMT
You can also configure Maven in your settings.xml file (~/.m2/settings.xml) to use the Nexus
repository built for the release.
Here's how I generated the installers for Emmanuel:
>     <profile>
>       <id>apacheds-nexus</id>
>       <repositories>
>         <repository>
>           <id>apacheds-nexus</id>
>           <name>ApacheDS Nexus</name>
>           <url>https://repository.apache.org/content/repositories/orgapachedirectory-073/</url>
>           <layout>default</layout>
>         </repository>
>       </repositories>
>       <pluginRepositories>
>         <pluginRepository>
>           <id>apacheds-nexus</id>
>           <name>ApacheDS Nexus</name>
>           <url>https://repository.apache.org/content/repositories/orgapachedirectory-073/</url>
>           <layout>default</layout>
>         </pluginRepository>
>       </pluginRepositories>
>     </profile>


For LDAP API, it would be:
>     <profile>
>       <id>api-nexus</id>
>       <repositories>
>         <repository>
>           <id>api-nexus</id>
>           <name>LDAP API Nexus</name>
>           <url>https://repository.apache.org/content/repositories/orgapachedirectory-068/</url>
>           <layout>default</layout>
>         </repository>
>       </repositories>
>       <pluginRepositories>
>         <pluginRepository>
>           <id>api-nexus</id>
>           <name>LDAPI API Nexus</name>
>           <url>https://repository.apache.org/content/repositories/orgapachedirectory-068/</url>
>           <layout>default</layout>
>         </pluginRepository>
>       </pluginRepositories>
>     </profile>

Off course, specify the name of the profile in the command line or add it by default in the
settings.xml:
>   <activeProfiles>
>     <activeProfile> api-nexus</activeProfile>
>   </activeProfiles>


Hope this helps,
Pierre-Arnaud

On 23 déc. 2012, at 08:29, Emmanuel Lécharny <elecharny@gmail.com> wrote:

> Le 12/23/12 4:28 AM, Kiran Ayyagari a écrit :
>> failed to build from the source cause the apacheds/pom.xml refers to
>> API/shared version 1.0.0-M14 instead of 1.0.0-M13
> 
> Ah, you have to build LDAP API M14 before building ApacheDS
> 
> -- 
> Regards,
> Cordialement,
> Emmanuel Lécharny
> www.iktek.com 
> 


Mime
View raw message