directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stéphane Démaret (JIRA) <j...@apache.org>
Subject [jira] [Commented] (DIRSERVER-1762) Switching log in debug make the service crash at startup
Date Thu, 15 Nov 2012 10:26:12 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-1762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13497908#comment-13497908
] 

Stéphane Démaret commented on DIRSERVER-1762:
---------------------------------------------

Good news, it seems there is no issue with the application, the problem was with the wrapper
which timeout at startup because the application is slower with the DEBUG option on.

I've added the following properties in the wrapper.conf to fix the issue : wrapper.startup.timeout=0
(default is 30)

I guess it would be a good idea to add this property in the wrapper.conf with a better default
value and/or a comment in the log4j file to indicate that the wrapper value must be changed.

Sorry I didn't catch it before but at least I know how to build the application now... BTW,
when I compile with the test on, it fails on the annotation project.
                
> Switching log in debug make the service crash at startup
> --------------------------------------------------------
>
>                 Key: DIRSERVER-1762
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1762
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: ldap
>    Affects Versions: 2.0.0-M8
>         Environment: Windows XP SP3
> java version "1.6.0_32"
> Java(TM) SE Runtime Environment (build 1.6.0_32-b05)
> Java HotSpot(TM) Client VM (build 20.7-b02, mixed mode, sharing)
>            Reporter: Stéphane Démaret
>            Priority: Minor
>             Fix For: 2.0.0-M9
>
>         Attachments: default.zip
>
>
> When I switch the log rootcategory to DEBUG in log4j.properties, I am unable to start
service.
> The last action logged in the log file is :
> [2012-11-11 20:53:02] DEBUG [org.apache.directory.shared.ldap.model.schema.registries.Registries]
- USING :
> I discovered this issue while investigating a problem with SSL communications with postgres
which cause another issue in Apache Directory.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message