directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-832) Setting up Eclipse correctly (The import org.apache.directory.shared cannot be resolved)?
Date Fri, 07 Sep 2012 12:31:07 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-832?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13450559#comment-13450559
] 

Pierre-Arnaud Marcelot commented on DIRSTUDIO-832:
--------------------------------------------------

Indeed, that page might not be really up-to-date with the 2.0 branch development.

The best thing would be to checkout this repository (which contains most of our sub-projects
trunks):
https://svn.apache.org/repos/asf/directory/trunks/

Apache Directory Studio depends mostly on Shared and ApacheDS.

So, the complete setup would be:
$ svn co https://svn.apache.org/repos/asf/directory/trunks/
$ cd trunks
$ mvn clean install
$ mvn eclipse:clean eclipse:eclipse
$ cd studio
$ mvn studio:clean studio:eclipse

Then you can import all projects in the following folders:
- apacheds
- shared
- studio

Eveything should be fine after that.
                
> Setting up Eclipse correctly (The import org.apache.directory.shared cannot be resolved)?
> -----------------------------------------------------------------------------------------
>
>                 Key: DIRSTUDIO-832
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-832
>             Project: Directory Studio
>          Issue Type: Question
>    Affects Versions: 2.0.0-M3
>         Environment: Windows 7 SP1 x64, Java 7 64-bit
>            Reporter: Aleks M
>            Priority: Minor
>
> Hello
> I'm trying to setup Eclipse according to these instructions:
> http://directory.apache.org/studio/working.html
> I have checked out the branch using:
> svn co https://svn.apache.org/repos/asf/directory/studio/trunk studio
> Then I ran:
> cd studio
> And:
> mvn install studio:eclipse
> I have installed SWTBot and the M2_REPO variable according to the docs.
> But after importing the projects into Eclipse I have a huge number of projects that are
marked with the white X on the red background icon.
> They are showing this error:
> The import org.apache.directory.shared cannot be resolved
> Any idea what went wrong?
> Thanks

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message