directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Super Nounouille (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-821) Where to get the public certificate used to sign the JAR of DS 1.5.3?
Date Tue, 31 Jul 2012 20:40:36 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-821?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13426094#comment-13426094
] 

Super Nounouille commented on DIRSTUDIO-821:
--------------------------------------------

Hello,

Thanks for the reply.

I'm not very comfortable with the licence stuff, especially the NOTICE. I'd like to add one
but my English is not "legal" enough to understand what I'm supposed to put in this file.
The license page shows an example taken from the httpd server, but I don't understand how
I could convert it to my case.

Anyway, I'm on the process of integrating 2.0.0-M3. Doing so, I have noticed some inconsistencies
between dependencies when I am updating my plugin target platform in the Eclipse preferences.
The LDAP browser feature declares the following dependencies toward plugins that can be found
on the update site but with invalid bundle versions (Bundle-Version in MANIFEST.MF):
Required plugin, version => Bundle-Version found in the plugin of the update site
org.apache.commons.codec, 1.6 => 1.6.0 (org.apache.commons.codec_1.6.0.jar)
org.bouncycastle.bcprov.jdk15, 140 => 140.0.0 (org.bouncycastle.bcprov.jdk15_140.0.0.jar)
org.apache.commons.io, 2.1 => 2.1.0 (org.apache.commons.io_2.1.0.jar)
org.apache.commons.lang, 2.6 => 2.6.0 (org.apache.commons.lang_2.6.0.jar)

Thanks,
                
> Where to get the public certificate used to sign the JAR of DS 1.5.3?
> ---------------------------------------------------------------------
>
>                 Key: DIRSTUDIO-821
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-821
>             Project: Directory Studio
>          Issue Type: Question
>          Components: studio-ldapbrowser
>    Affects Versions: 1.5.3
>            Reporter: Super Nounouille
>            Priority: Blocker
>
> Hello,
> 2 questions, actually.
> 1/ I would like to ship ADS 1.5.3 into an Eclipse RCP application I'm writing: may I?
This app is also released under the Apache Licence.
> 2/ I cannot generate the P2 metadata of my app if I embed ADS. I think this is because
the public certificate of the certificate used to sign the pug-in JAR files is not present
in my JDK cacerts file. Where to get this public certificate? For information, the one I'm
interested in expired on 31/01/10 18:28
> Thanks

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message