directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roman Dawydkin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-817) Installation failure for Eclipse 4.2
Date Mon, 02 Jul 2012 11:38:22 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-817?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13405010#comment-13405010
] 

Roman Dawydkin commented on DIRSTUDIO-817:
------------------------------------------

Excerpt from 4.2 migration guide:

5. Update Manager bundles removed
What is affected: Clients that rely on the provisional API or implementation found in the
following bundles:

org.eclipse.update.core
org.eclipse.update.core.win32
org.eclipse.update.scheduler
org.eclipse.update.ui

Description: These provisional APIs were deprecated and superseded by new API provided by
Equinox p2 in Eclipse 3.4. These bundles have been removed from the Eclipse SDK in 4.2, but
remain available and fully compatible with 4.2 should any application or product require them.

Action required: Clients that rely on the provisional API or implementation in these bundles
should migrate to the functionality and API provided by Equinox p2. Alternatively, products
can install these bundles from the Eclipse 3.8 repository and they will continue to function
in Eclipse 4.2-based applications.
                
> Installation failure for Eclipse 4.2
> ------------------------------------
>
>                 Key: DIRSTUDIO-817
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-817
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-installer, studio-rcp, studio-updatesite
>    Affects Versions: 2.0.0-M3
>         Environment: Windows 7, JDK 7
>            Reporter: Roman Dawydkin
>
> Message detail from installation error:
> Cannot complete the install because one or more required items could not be found.
> Software currently installed: Apache Directory Studio RCP 2.0.0.v20120224 (org.apache.directory.studio.rcp.feature.feature.group
2.0.0.v20120224)
> Missing requirement: Apache Directory Studio RCP 2.0.0.v20120224 (org.apache.directory.studio.rcp
2.0.0.v20120224) requires 'bundle org.eclipse.update.core 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: Apache Directory Studio RCP 2.0.0.v20120224 (org.apache.directory.studio.rcp.feature.feature.group
2.0.0.v20120224)
> To: org.apache.directory.studio.rcp [2.0.0.v20120224]

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message