directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alberto Aresca <alberto.are...@gmail.com>
Subject [ApacheDS] Problem with server.xml and spring 3.1
Date Tue, 24 Apr 2012 23:33:19 GMT
Hi all,

I'm working on integrating ldap authentication within my webapp. To do
so I planned to create an integration test case to validate that my
spring security configuration works against a standard ldap.

To complete this task I'm using apacheds and I'm creatin an instance
of the ldap server via the FileSystemXmlApplicationContext class,
passing it a proper server.xml configuration. However since my
application depends on spring 3.1 I'm getting the SAXParseException:
cvc-elt.1: Cannot find the declaration of element 'spring:beans'.

If i roll back to spring 2.5.6 this does not happen. However because
of my environment rolling back to such an old version of spring is not
an option. Is there any other way to achieve my goal?

Cheers

-- 
Alberto Aresca

Mime
View raw message