directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Spencer Burgoyne <sburgo...@part.net>
Subject ERR_732
Date Fri, 09 Mar 2012 23:55:50 GMT
My company has decided to use an LDAP server for authentication of 
internal applications and we decided to go with Apache Directory Server. 
I adjusted one of our applications to use the server for authentication 
via a JNDIRealm on Tomcat. As I developed and tested these changes, I 
would occasionally see 'ERR_732 Cannot process a Request while binding' 
but it usually only occurred right after I restarted the server, so I 
didn't think much of it. The server is now in use and the issue has been 
appearing sporadically for many employees. I have googled like crazy but 
I cannot find any cause for this issue that applies to our application. 
Here is the JNDI Realm that I am using:
<?xml version="1.0" encoding="UTF-8"?>
<Context  reloadable="true" >
<Realm className="org.apache.catalina.realm.LdapJdbcRealm"
         debug="99"
         resourceName="LDAP Auth"
         connectionName="xxxx"
         connectionPassword="xxxx"
         connectionURL="xxxx"
         alternateURL="xxxx"
         driverName="xxxx"
         userPattern="uid={0}, xxxx, xxxx"
         dbConnectionName="xxxx"
         dbConnectionPassword="xxxx"
           dbConnectionURL="xxxx"
         userRoleTable="xxxx"
         roleNameCol="xxxx"
         userTable="xxxx"
         userNameCol="xxxx"/>
</Context>
And the authentication does work often so I know these settings, for the 
most part, must be correct. Have any other users encountered a similar 
issue? Any help would be appreciate, thanks.

Spencer

Mime
View raw message