directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lécharny <elecha...@apache.org>
Subject Re: Strange issues with shared-all source jar generation...
Date Sat, 28 Jan 2012 16:38:34 GMT
On 1/28/12 5:23 PM, Alex Karasulu wrote:
> On Sat, Jan 28, 2012 at 5:28 PM, Emmanuel Lécharny<elecharny@apache.org>wrote:
>
>> On 1/28/12 3:18 PM, Alex Karasulu wrote:
>>
>>> On Sat, Jan 28, 2012 at 10:22 AM, Emmanuel Lecharny<elecharny@gmail.com>*
>>> *wrote:
>>>
>>>   Hi guys,
>>>> yesterday we spent a couple of hours with Pierre-Arnaud trying to
>>>> determinate why the shared-all compilation was failing on linux. After
>>>> tens
>>>> of different tests, we found that :
>>>> - building shared-all on Mac OSX, with maven 3.0.3 and Java 6 works fine
>>>> - building shared-all on Ubuntu 11.10 with maven 3.0.3 and Java 6
>>>> generates an empty source jar
>>>> - building shared-all on Ubuntu 11.10 with maven 3.0.3 and Java 7
>>>> produces
>>>> an error
>>>>
>>>> I created a JIRA for that : http://jira.codehaus.org/****
>>>> browse/MSHADE-108<http://jira.codehaus.org/**browse/MSHADE-108><
>>>> http://jira.**codehaus.org/browse/MSHADE-108<http://jira.codehaus.org/browse/MSHADE-108>
>>>> **>
>>>>
>>>>
>>>> It's really really strange. I guess that there is an error in the way the
>>>> shade plugin is working and it may be related with the fact that Mac OSX
>>>> is
>>>> based on a case insensitive file system, or something like that.
>>>>
>>>>   FYI I found this bug too. I found that if shared is cleaned before the
>>> build then everything proceeds well. Like before doing the mvn install
>>> just
>>> do an mvn clean in shared first. Then the entire build works fine.
>>> Something is left that makes the Shade plugin fail exactly for some of the
>>> reasons you suspect (I suspect as well).
>>>
>> What is your environement ?
>>
>>
>>
> akarasulu@stein:~$ mvn -v
> Apache Maven 3.0.3 (r1075438; 2011-02-28 19:31:09+0200)
> Maven home: /opt/tools/maven/default
> Java version: 1.6.0_26, vendor: Sun Microsystems Inc.
> Java home: /usr/lib/jvm/java-6-sun-1.6.0.26/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "3.0.0-15-generic", arch: "amd64", family: "unix"
>
> akarasulu@stein:~$ uname -a
> Linux stein 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012
> x86_64 x86_64 x86_64 GNU/Linux

yes, it's a linux issue...

I'll see if I can debug the shade plugin.
>
>


-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com


Mime
View raw message