directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRAPI-58) Method org.apache.directory.ldap.client.api.LdapConnection.loadSchema() should be renamed as loadDefaultSchema() to avoid confusion
Date Tue, 25 Oct 2011 16:02:32 GMT
Method org.apache.directory.ldap.client.api.LdapConnection.loadSchema() should be renamed as
loadDefaultSchema() to avoid confusion 
------------------------------------------------------------------------------------------------------------------------------------

                 Key: DIRAPI-58
                 URL: https://issues.apache.org/jira/browse/DIRAPI-58
             Project: Directory Client API
          Issue Type: Improvement
    Affects Versions: 1.0.0-M8, 1.0.0-M7, 1.0.0-M6, 1.0.0-M5, 1.0.0-M4, 1.0.0-M3, 1.0.0-M2,
1.0.0-M1
            Reporter: Pierre-Arnaud Marcelot
             Fix For: 1.0.0-M9


At first, I thought the method org.apache.directory.ldap.client.api.LdapConnection.loadSchema()
could be used to load the schema of the remote server via the connection.

Instead, it turned out it is loading the default (ApacheDS) schema bundled with API.

Maybe it would be better to rename this method as loadDefaultSchema() to avoid confusion.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message