directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Knecht <fel...@apache.org>
Subject Re: [VOTE] Release of Apache Directory Server 2.0.0-M3
Date Sun, 11 Sep 2011 09:16:42 GMT
On 09/11/2011 09:40 AM, Kiran Ayyagari wrote:
> I have checked out the source (apacheds and shared from tag 2.0.0-M3)
> and the build went fine with mvn clean install -Dintegration
> have also tested the archive installer.
>
> Felix, can you please give it another try, will wait for your response
> before I cast my vote.

I tried it on another machine (both fedora 15 64-bit) and do have still 
the same build issues. It doesn't matter if the -Dintegration flag is 
set or not. It also doesn't matter which JDK I use 
(jdk1.6.0_27|jdk1.7.0). When using jdk-1.7 I get different Exceptions 
but in the same test classes:

"
-------------------------------------------------------------------------------
Test set: org.apache.directory.server.kerberos.kdc.KerberosTcpITest
-------------------------------------------------------------------------------
Tests run: 5, Failures: 0, Errors: 4, Skipped: 1, Time elapsed: 3.201 
sec <<< FAILURE!
testObtainTickets_AES128(org.apache.directory.server.kerberos.kdc.KerberosTcpITest) 
  Time elapsed: 0.023 sec  <<< ERROR!
java.lang.ClassNotFoundException: sun.security.krb5.KrbKdcReq
         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
"

I can remember having already strange effects months ago with failing 
test cases everybody else hadn't but I never found out the reason why. 
That's why I asked if anybody else has these failures. If not it seems 
to be a setup problem of my machines ...

As this seems to be a problem of my setup I vote

[X]  0 abstain


>
>
> On Sat, Sep 10, 2011 at 1:00 PM, Felix Knecht<felixk@apache.org>  wrote:
>> On 09/10/2011 08:23 AM, Emmanuel Lecharny wrote:
>>>
>>> On 9/10/11 7:50 AM, Felix Knecht wrote:
>>>>
>>>> On 09/10/2011 12:45 AM, Emmanuel Lecharny wrote:
>>>>>
>>>>> On 9/9/11 10:21 PM, Felix Knecht wrote:
>>>>>>
>>>>>> I can't build the tagged source (Revision 1167253) because of failing
>>>>>> test cases when doing a checkout (of course starting also with an
>>>>>> empty local maven repository). See files.
>>>>>
>>>>> Hmmmm...
>>>>>
>>>>> I just checked out the
>>>>> http://svn.apache.org/repos/asf/directory/apacheds/tags/2.0.0-M3 and
ran
>>>>> mvn clean install -Dintegration, after having removed my
>>>>> .m2/repository/org/apache/directory directory.
>>>>>
>>>>> [INFO]
>>>>> ------------------------------------------------------------------------
>>>>> [INFO] BUILD SUCCESS
>>>>> [INFO]
>>>>> ------------------------------------------------------------------------
>>>>> [INFO] Total time: 19:05.768s
>>>>> [INFO] Finished at: Sat Sep 10 00:28:52 CEST 2011
>>>>> [INFO] Final Memory: 48M/116M
>>>>> [INFO]
>>>>> ------------------------------------------------------------------------
>>>>>
>>>>> Are you sure you have the correct shared jars ?
>>>>
>>>> No, but I did a 'rm -rf ~/.m2/repository' before to be sure all
>>>> dependencies needs to be downloaded.
>>>
>>> Hmmm. I did the exact same thing, removing all my repo, and rebuild
>>> apacheds taken from the 2.0.0-M3 tag.
>>>
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] BUILD SUCCESS
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] Total time: 21:42.053s
>>> [INFO] Finished at: Sat Sep 10 08:21:05 CEST 2011
>>> [INFO] Final Memory: 49M/115M
>>> [INFO]
>>> ------------------------------------------------------------------------
>>>
>>>>
>>>> I tried now with jdk 1.7 - it fails also. I need to do some more
>>>> investigations, let's see if I can get it building in a Windows VM.
>>>
>>> What are the errors you get ?
>>
>> I attached them in my first mail.
>>
>>>
>>>>
>>>> BTW
>>>> Did you build it successfully on a 64- or a 32-bit OS?
>>>
>>> 64 bit.
>>>
>>>
>>
>>
>
>
>


Mime
View raw message