directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot (JIRA)" <>
Subject [jira] [Updated] (DIRSERVER-1586) 2.0 does not have a way to load external Ldifs (h.350)
Date Fri, 26 Aug 2011 16:26:32 GMT


Pierre-Arnaud Marcelot updated DIRSERVER-1586:

    Fix Version/s:     (was: 2.0.0-M2)

> 2.0 does not have a way to load external Ldifs (h.350)
> ------------------------------------------------------
>                 Key: DIRSERVER-1586
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 2.0.0
>         Environment: Running on windows XP and Windows 2003 server
>            Reporter: Steve hammond
>             Fix For: 2.0.0-M3
>         Attachments: XmppURIObject.ldif, commObject.ldif
> We need a method that is consistent with ldif files exported from Apache directory Studio,
that can be loaded to extend the schema of our server.
> In 1.5.3 I did ApacheDS.setLdifDirectory, then when the LDAP server started, it imported
and used the ldif definitions in that directory.  I have exhausted all methods I could find
to load these LDIF files.
> I tried ApplyLdifs, but that takes a description parameter that is part of Junit, not
real good for production code, and the Description I can get out of Junit does not have the
getAnnotation method on it.
> I tried DSAnnotationProcessor.injectLdifFiles directly, but it could never open the file
names i gave it.
> I tried writing my own injectLdifFiles method, but always got an error when trying to
add attributes to an objectclass that I had just added, saying that this objectClass is not
yet loaded.
> I tried making my own implementation of AbstractSchemaLoader, but that pukes saying that
all schemas must have a valid creatorsName attribute.

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message