directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: Issue building
Date Fri, 08 Jul 2011 10:00:42 GMT
Yeah, indeed.

At the time of the release, there was no Maven 3, but Maven 2 instead.

However, if you want to build 1.5.3 using Maven 3 you need to move the following lines from
"[root]/repository/pom.xml" to "[root]/pom.xml":
>   <repositories>
>     <repository>
>       <id>studio.repository</id>
>       <name>Studio Provided Repository</name>
>       <url>file://${project.basedir}</url>
>     </repository>
>   </repositories>

Things have changed in Maven 3 regarding repositories and our "repository hack" for Eclipse
dependencies is no longer working.
Modifying the files as mentioned fixes that.

Hope this helps,
Pierre-Arnaud


On 8 juil. 2011, at 11:50, Johan Swensson wrote:

> Yes I am, is that the problem?
> 
> 
> 
>> Hi Johan,
> 
>> Are you using Maven 3?
> 
>> Regards,
>> Pierre-Arnaud
> 
>> On 8 juil. 2011, at 09:25, Johan Swensson wrote:
> 
>> Hi
>> 
>> I'm trying to build Apache Directory Studio from source from the 1.5.3
>> tarball but I'm running into some deps issues.
>> 
>> mvn clean install:
>> 
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 2:45.737s
>> [INFO] Finished at: Fri Jul 08 09:20:30 CEST 2011
>> [INFO] Final Memory: 9M/23M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-dependency-plugin:2.1:unpack
>> (unpack-language-packs) on project studio-build: Unable to find artifact.
>> Could not find artifact
>> org.eclipse.languagepack:BabelLanguagePack-eclipse-de:zip:3.5.0.v20090620043401
>> in central (http://repo1.maven.org/maven2)
>> [ERROR]
>> [ERROR] Try downloading the file manually from the project website.
>> [ERROR]
>> [ERROR] Then, install it using the command:
>> [ERROR] mvn install:install-file -DgroupId=org.eclipse.languagepack
>> -DartifactId=BabelLanguagePack-eclipse-de -Dversion=3.5.0.v20090620043401
>> -Dpackaging=zip -Dfile=/path/to/file
>> [ERROR]
>> [ERROR] Alternatively, if you host your own repository you can deploy the
>> file there:
>> [ERROR] mvn deploy:deploy-file -DgroupId=org.eclipse.languagepack
>> -DartifactId=BabelLanguagePack-eclipse-de -Dversion=3.5.0.v20090620043401
>> -Dpackaging=zip -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>> [ERROR]
>> [ERROR]
>> [ERROR]
>> org.eclipse.languagepack:BabelLanguagePack-eclipse-de:zip:3.5.0.v20090620043401
>> [ERROR]
>> [ERROR] from the specified remote repositories:
>> [ERROR] apache.snapshots (http://repository.apache.org/snapshots,
>> releases=false, snapshots=true),
>> [ERROR] central (http://repo1.maven.org/maven2, releases=true,
>> snapshots=false)
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with the
>> -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> error: Bad exit status from /var/tmp/rpm-tmp.jcC96M (%build)
>> 


Mime
View raw message