directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <>
Subject Re: svn commit: r1138906 - in /directory/apacheds/trunk: jdbm-partition/src/main/java/org/apache/directory/server/core/partition/impl/btree/jdbm/ xdbm-partition/src/main/java/org/apache/directory/server/xdbm/ xdbm-partition/src/main/java/org/apache/d
Date Fri, 24 Jun 2011 08:05:20 GMT
On 6/24/11 10:00 AM, Alex Karasulu wrote:
> Can you explain why you did this? Sounds like a code reduction cleanup
> but if you can elaborate a bit more that would be great.

Sure ! Those methods are already declared in their parent class, so no 
need to declare them in the inherited class, when their body just do 

It's basically removal of duplicated code.

I also renamed the delete() method to remove(), to be consistent in the 
naming : why should we used remove or delete to do the exact same thing?

Emmanuel L├ęcharny

View raw message