directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: svn commit: r1138408 - in /directory/apacheds/trunk: core/src/main/java/org/apache/directory/server/core/ jdbm-partition/src/main/java/org/apache/directory/server/core/partition/impl/btree/jdbm/ xdbm-partition/src/main/java/org/apache/directory/s
Date Wed, 22 Jun 2011 12:07:10 GMT
On 6/22/11 1:58 PM, Kiran Ayyagari wrote:
> On Wed, Jun 22, 2011 at 5:02 PM,<elecharny@apache.org>  wrote:
>> Author: elecharny
>> Date: Wed Jun 22 11:32:15 2011
>> New Revision: 1138408
>>
>> URL: http://svn.apache.org/viewvc?rev=1138408&view=rev
>> Log:
>> Minor refactoring and improvement
>>
>> Modified:
>>     directory/apacheds/trunk/core/src/main/java/org/apache/directory/server/core/DefaultDirectoryService.java
>>     directory/apacheds/trunk/jdbm-partition/src/main/java/org/apache/directory/server/core/partition/impl/btree/jdbm/JdbmStore.java
>>     directory/apacheds/trunk/xdbm-partition/src/main/java/org/apache/directory/server/xdbm/impl/avl/AvlStore.java
>>
>> Modified: directory/apacheds/trunk/core/src/main/java/org/apache/directory/server/core/DefaultDirectoryService.java
>> URL: http://svn.apache.org/viewvc/directory/apacheds/trunk/core/src/main/java/org/apache/directory/server/core/DefaultDirectoryService.java?rev=1138408&r1=1138407&r2=1138408&view=diff
>> ==============================================================================
>> --- directory/apacheds/trunk/core/src/main/java/org/apache/directory/server/core/DefaultDirectoryService.java
(original)
>> +++ directory/apacheds/trunk/core/src/main/java/org/apache/directory/server/core/DefaultDirectoryService.java
Wed Jun 22 11:32:15 2011
>> @@ -989,12 +989,12 @@ public class DefaultDirectoryService imp
>>          // load the last stored valid CSN value
>>          LookupOperationContext loc = new LookupOperationContext( getAdminSession()
);
>>          loc.setDn( systemPartition.getSuffix() );
>> -        loc.setAttrsId( new String[]{ "+" } );
>> +        loc.setAttrsId( new String[]{ SchemaConstants.CONTEXT_CSN_AT } );
> actually changing it to loc.setAttrsId( new String[]{ "*", "+" } );
> will make it faster, the BaseEntryFilteringCursor's filterContents()
> returns immediately.
>
> P.S:- in this case we might be targeting readability, but just thought
> of pointing it.

Yes, that's true, but it's not a critical part, so I'd rather favor 
readability in this very case...


-- 
Regards,
Cordialement,
Emmanuel L├ęcharny
www.iktek.com


Mime
View raw message