directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiran Ayyagari <kayyag...@apache.org>
Subject Re: Custom Schema
Date Sun, 24 Apr 2011 14:51:05 GMT
do you have a test case to reproduce the error you are encountering?
that will help us to understand your issue better

On Sun, Apr 24, 2011 at 5:16 PM, Rajesh <rajesh@vimukti.com> wrote:
> I have been trying to start the server with a custom schema of my own since
> last one week.  In that process I am trying to understand how the schema
> gets loaded. I found a small bug in that process.
>
> DefaultSchema.addDependencies  method is implemented wrong. The src, dst for
> arraycopy should be interchanged.
>
> After I loaded my schema I got error in the following line in
> DefaultPartitionNexus constructor.
>
>  rootDSE.put( SchemaConstants.SUBSCHEMA_SUBENTRY_AT,
> ServerDNConstants.CN_SCHEMA_DN );
>
>
> ERR_04464 Error while adding values into the {0} attribute. Error :
> ERR_04269 ATTRIBUTE_TYPE for OID subschemasubentry does not exist!
>
> I understand the error that my schema does not define this AttributeType.
> But what I did not understand is why "subschemasubentry" is being treated as
> OID. In some places there are checks like OID.isOid to make sure that all
> OIDs of all AttributeTypes are really OIDs. And in many other places names
> are being used as OIDs.
>
> I got little confused. Can some one clear my doubts...
>
> Thanks in advance
>
> --
>
> Rajesh Akkineni
>
>



-- 
Kiran Ayyagari

Mime
View raw message