directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KathMora <km...@searchtechnologies.com>
Subject Re: [ApacheDS] Writing a custom partition
Date Mon, 18 Apr 2011 18:09:23 GMT

Hi everyone,

I'm trying out the  same example to create a custom partition (
http://directory.apache.org/apacheds/1.5/61-how-to-write-a-simple-custom-partition-for-apacheds.htm
http://directory.apache.org/apacheds/1.5/61-how-to-write-a-simple-custom-partition-for-apacheds.htm
)

I've downloaded the code from 
http://svn.apache.org/repos/asf/directory/sandbox/szoerner/helloWorldPartition
http://svn.apache.org/repos/asf/directory/sandbox/szoerner/helloWorldPartition 
and didn't make any changes to it. I just created the jar by running "mvn
install" and copying the jar to lib/ext.
When I try to start the Apache DS service I get the attached error. 

I'm not sure if this is causing it, but the jar versions in the pom.xml file
for ldap are 0.9.15 and the ones in Apache DS are 0.9.17.

Do you have any idea why I'm getting this error?


Thomas Sahlin wrote:
> 
> Hi everyone,
> 
> I'm trying out the example on how to write a simple custom partition (it's 
> at 
> http://directory.apache.org/apacheds/1.5/61-how-to-write-a-simple-custom-partition-for-apacheds.html).
> I downloaded the code from
> http://svn.apache.org/repos/asf/directory/sandbox/szoerner/helloWorldPartition.
> I've created the jar by running "mvn install"  and copied it to lib/ext.
> hen I try to 
> 
> I've created a class called TestPartition (pretty much identical to the 
> example HelloWorldPartition) and built it into a jar called LDAPTest.jar.
> 
> In /var/lib/apacheds-1.5.5/default/conf/server.xml I've added the
> following:
> 
>   ...
>   </jdbmPartition>
> 
>   <s:bean id="testPartition" class="se.invented.apacheds.TestPartition">
>     <s:property name="suffix" value="ou=hello" />
>   </s:bean>
> </partitions>
> 
> I've placed LDAPTest.jar inside /opt/apacheds-1.5.5/lib and added the 
> following to /opt/apacheds-1.5.5/conf/apacheds.conf:
> 
> wrapper.java.classpath.6=../lib/LDAPTest.jar
> 
> When I start the server it runs for a second and then dies with the
> attached 
> log message.
> 
> What am I doing wrong?
> 
> Thanks,
> 
> Thomas Sahlin 
> 
>  
> 

-- 
View this message in context: http://old.nabble.com/-ApacheDS--Writing-a-custom-partition-tp26478216p31426299.html
Sent from the Apache Directory Project mailing list archive at Nabble.com.


Mime
View raw message