On Wed, Mar 30, 2011 at 12:13 PM, Pierre-Arnaud Marcelot <pa@marcelot.net> wrote:
Hi Emmanuel,

Doco looks fine to me.

Great doco indeed - thanks Emm!
I think the naming of two methods could be improved for readability and coherence with standard Java and our own coding standards:
- boolean isHR(); ---> boolean isHumanReadable();
- boolean instanceOf( AttributeType attributeType ); ---> boolean isInstanceOf( AttributeType attributeType );

Very minor concerns...

Yeah this does improve readability.  +1