directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject [Shared] Problems building the site
Date Sun, 06 Mar 2011 19:42:41 GMT
Hi devs,

there are problems building the 'shared' Maven site. It fails with the
following error:

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:site
(default-site) on project shared-parent: failed to get Reports: Failed
to execute goal
org.apache.maven.plugins:maven-dependency-plugin:2.1:copy (copy) on
project shared-integ: Error copying artifact from
/Users/seelmann/Development/Apache/svn/dir-trunks/shared/ldap/extras/codec/target/classes
to /Users/seelmann/Development/Apache/svn/dir-trunks/shared/integ/target/pluginDirectory/classes:
/Users/seelmann/Development/Apache/svn/dir-trunks/shared/ldap/extras/codec/target/classes
(No such file or directory) -> [Help 1]

The reason is that the shared-integ configures the
dependency-maven-plugin to copy the shared-ldap-extras-codec artifact.
But when running "mvn site" (the same happens when running "mvn test")
the artifact path does not point to the target/*.jar file but to the
target/classes folder.

One workaround could be to exclude the shared-integ module from site
generation, by activating the shared-integ module only when
-Dintegration property is set. But that's not nice because "mvn test
-Dintegration" would still fail. Any ideas how to configure
shared-integ better?

Kind regards
Stefan

Mime
View raw message