directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot>
Subject Re: Renaming EntryAttribute to Attribute ?
Date Wed, 30 Mar 2011 14:26:53 GMT
Hi Emmanuel,

Makes totally sense to me.

It seems more obvious than EntryAttribute.


On 30 mars 2011, at 16:21, Emmanuel Lecharny wrote:

> Hi guys,
> when I initially started to write the EntryAttribute class, I picked this name to avoid
a confusion with the JNDI Attribute class. bck 2 years ago, it was important, because we had
a hell lot of JNDI code all over the shared and server code. Mixing both name would have been
a nightmare, with package expended into the source instead of just having the imports.
> Now that we have been able to get rid of most of the JNDI calls, it might be a good idea
to move the name to use Attribute.
> wdyt ?
> -- 
> Regards,
> Cordialement,
> Emmanuel L├ęcharny

View raw message