directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot>
Subject Re: Some few classes that are probably stored at the right place...
Date Wed, 30 Mar 2011 13:50:53 GMT
Hi Alex,

On 30 mars 2011, at 14:24, Alex Karasulu wrote:

> On Wed, Mar 30, 2011 at 12:20 PM, Pierre-Arnaud Marcelot <> wrote:
> Hi Emmanuel,
> +1
> SearchScope could be in ''.
> LdapURL could in ''.
> Shouldn't we also rename 'LdapURL' as 'LdapUrl' to match other class names (like Dn,
Rdn, Oid, etc.)?
> Regards,
> Pierre-Arnaud
> My same thoughts. LdapUrl should go into message pkg too though - why have an extra package
with just one or two classes?

Readability and longevity I guess.
We might need to add more classes related to LdapUrl later, like an URL factory or more.
Having this extra package ensures that we won't be tempted to move it afterwards, breaking
compatibility in client applications.

At first, I was hesitating between either '' or ''.

Are you picking 'message' because LdapUrl is somehow related to referrals?
I've just verified and none of the classes under the 'message' package uses LdapUrl (not even
Other than that, I don't really see the link between the classes under this package and the
LdapUrl class...


> Regards,
> Alex

View raw message