directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: Problems trying to get back in sync with ADS
Date Fri, 04 Feb 2011 15:08:01 GMT
Hi Richard,

On 4 févr. 2011, at 15:07, Richard Feezel wrote:

> MUCH Better!  I now have only 44 errors, all of them:
> 
> "The specified version does not have the correct format (major.minor.micro.qualifier)
or contains invalid characters"
> 
> and seem to be references to 
> 
> version="$pom.version"
> 
> in various feature.xml files.

This is due to the fact that the version number is automatically filtered by Maven in the
built files, but not in the original file itself which stays with the expression.
You can safely close all the '*.feature' projects in Eclipse.

> I also got a build error which I see is attributed to an Eclipse issue:
> 
> Errors occurred during the build.
> Errors running builder 'Plug-in Manifest Builder' on project 'ldapbrowser.ui'.
> 1

That's an Eclipse bug.
It will popup every time you launch the rebuild of projects related to the 'ldapbrowser.ui'
Studio project.
But hopefully it does not prevent Studio from running when launched as an 'Eclipse Application'
afterwards.
See this link [1] and the other thread on the ML named "[Studio] Anyone know how to get rid
of this eclipse error?" for more details.

Regards,
Pierre-Arnaud

[1] - https://bugs.eclipse.org/bugs/show_bug.cgi?id=308741

> 
> On Fri, Feb 4, 2011 at 2:00 AM, Stefan Seelmann <seelmann@apache.org> wrote:
> mvn studio:eclipse
> 
> 
> 
> -- 
> Richard M Feezel
> rfeezel@gmail.com


Mime
View raw message