directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abdel Belkasri <belka...@hotmail.com>
Subject RE: objectClass not available
Date Tue, 01 Mar 2011 02:00:25 GMT

I believe I did, but it didn't help. I tried the reload at all levels: root, ou=schema, and
subschema...must be a bug!
 


Date: Mon, 28 Feb 2011 09:56:22 +0100
From: pa@marcelot.net
To: dev@directory.apache.org
Subject: Re: RE: objectClass not available



There is a button to reload the schema next to the list where you select the object class
of the new entry you want to create.


You could use that if you don't find the expected object classes in the list.

Regards,
Pierre-Arnaud

On dimanche 27 février 2011 at 22:57, Abdel Belkasri wrote:


That worked. Thanks Kiran. I had to recreate the connection again. Something not working well
in the studio, apparently it is caching and does not invalidate the cache even if you restart
the apacheds server...that must be wrong! right guys?
 
> Date: Mon, 28 Feb 2011 01:36:33 +0530
> Subject: Re: objectClass not available
> From: kayyagari@apache.org
> To: dev@directory.apache.org
> 
> Does your 'opensso' depends on any other schema, if yes then make sure
> you enable those schemas also (only if they are disabled)
> then restart the server
> otherwise you can do as mentioned here
> http://markmail.org/message/kijrud47mkriu4hx
> 
> 
> On Mon, Feb 28, 2011 at 1:29 AM, Abdel Belkasri <belkasri@hotmail.com> wrote:
> > Thanks Kiran for your answer. Yes I am using the ApacheDS Studio. I
> > refreshed the connection. I even restarted the server.
> >
> > PS: To create an entry, I right click on the partition (dc=example,dc=com)
> > and select "New Entry..", the "create entery from scratch), then I see the
> > list which does not have inetUser!
> >
> >> Date: Mon, 28 Feb 2011 01:12:56 +0530
> >> Subject: Re: objectClass not available
> >> From: kayyagari@apache.org
> >> To: dev@directory.apache.org
> >>
> >> On Mon, Feb 28, 2011 at 1:02 AM, Abdel Belkasri <belkasri@hotmail.com>
> >> wrote:
> >> > Hi,
> >> > I am new to ApacheDS, so this question may be trivial, and hopefully
> >> > someone
> >> > can volunteer to answer it in a shot email.
> >> >
> >> > I need to use the inetUser. I noticed that it's not available in the
> >> > apacheDS default install. So I followed the instruction to extend the
> >> > schema. It was successful and now I can see my added schema under:
> >> > Root DSE --> ou=schema --> cn=opensso (I named my schema opensso).
> >> >
> >> > Still when I want to create an entery under dc=example,dc=com I cannot
> >> > see
> >> > inetUser (or any  of the added objectClass) under: "availabel Object
> >> > class"
> >> > list!
> >> >
> >> > Any idea why? what am I doing wrong.
> >> >
> >> I assume you are using Studio, then just refresh the schema(open
> >> connection properties to do this) and you should see these
> >> > Thanks in Advance.
> >> > --Abdel
> >> >
> >>
> >>
> >>
> >> --
> >> Kiran Ayyagari
> >
> 
> 
> 
> -- 
> Kiran Ayyagari


 		 	   		  
Mime
View raw message