directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <>
Subject Re: Some more thoughts about the Dn class
Date Thu, 17 Feb 2011 17:50:10 GMT
On Thu, Feb 17, 2011 at 3:00 PM, Emmanuel Lécharny <> wrote:
> On 2/17/11 1:27 PM, Alex Karasulu wrote:
>> On Thu, Feb 17, 2011 at 2:19 PM, Emmanuel Lécharny<>
>>  wrote:
>>> On 2/17/11 12:07 PM, Alex Karasulu wrote:
>>>> getAncestorOf/getDescendantOf ? Or use getAscendant/getDescendant ?
>>>> Yeah getAncestorOf/getDescendantOf sounds like it flows better and
>>>> clarifies that we're taking this from the dn the operation is applied
>>>> to.
>>> I like it better too. Will rename to use those names.
>> Well hold on a second with the getDescendantOf operation. I think we
>> have some outstanding issues with it. Please see my previous post.
> I'm not closing the door here. Here is what I suggest : I'll move the API to
> use those name *for the moment*, in order to get rid of the old
> getPrefix/getSuffix names, but we can discuss those names further until the
> RC1. If we find a better name, I'll change them, it's a 5 mins task. I'm
> *not* considering that as  final move, again.

OK thanks. I just did not want to have someone say, 'we agreed to it this way'.

> What is important is really to reach a point we all more or less agree,
> which is not easy, as it's not a technical matter, but much more a mix of
> many concerns :
> - semantic
> - ease of use
> - language (correct and accurate english)

Yes agreed.

> We should not expect to get the API defintion to be a breeze, I'm not really
> surprised that such things raise discussions like the one we are having.
> Frankly, if we were in a room, all of us, it would be exactly the same thing
> with people thinking this, other thinking that, etc, but nobody would hear
> about those disagreements outside the room. We are doing that in the open,
> and even if we don't agree on everything, at then end the result will be the
> same : we will reach consensus, and we will get something better than any
> decision made by one single person.



View raw message