directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <akaras...@apache.org>
Subject Re: [Shared] Last night's efforts
Date Tue, 08 Feb 2011 12:10:57 GMT
On Tue, Feb 8, 2011 at 12:26 PM, Emmanuel Lecharny <elecharny@gmail.com> wrote:
> Hi Alex,
>
> On 2/8/11 5:32 AM, Alex Karasulu wrote:
>>
>> First I got the build working with the shared-ldap-extras-codec
>> module. I still need to get studio build to use this jar as well. Also
>> I discovered that I accidentally move these notification of disconnect
>> extended operations to the extras codec project. Have not moved them
>> out yet but they must be put somewhere else since they're not
>> optional.
>
> After a good night, my pb with ldap-extras have magically been solved :)
> Nothing resist to a good night sleep (or is that you who fixed it ? ;)

Yeah took care of some things that were broken.

>> Second I succeeded in adding an embedded Felix instance into the
>> DefaultLdapCodecService. The extras controls are loading just fine.
>> There are however some issues with Felix and it's felix-cache
>> directories with concurrent tests. I don't know exactly what's going
>> on but this is something I can take care of tomorrow. This stuff is
>> *VERY* raw and needs to be cleaned up. Still need to figure out how to
>> properly conduct integration tests.
>> I have one in shared-integ but it's behaving very oddly. I had to user
>> the maven-dependency-plugin to copy over the extras bundle for testing
>> it's load into the embedded felix instance. However something is not
>> right at all. It seems to always work regardless of where I point the
>> plugin directory in surefire for the codec service.
>
> I have an issue when running integration tests with OSGi :
> -------------------------------------------------------------------------------
> Test set: org.apache.directory.server.factory.CreateKdcServerAnnotationTest
> -------------------------------------------------------------------------------
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 2.426 sec
> <<< FAILURE!
> testCreateKdcServer(org.apache.directory.server.factory.CreateKdcServerAnnotationTest)
>  Time elapsed: 2.389 sec <<< ERROR!
> java.lang.SecurityException: class "org.osgi.framework.ServiceException"'s

Yeah I still have to figure out what is happening here.

> I have no idea what it means...

That makes both of us.

> Just wondering : wouldn't it be a good idea to release M1 as is, and
> switching to M2 for felix integration ? That would mean I have to inject my
> modifications into trunk, but that should not be a big problem.
>
> thoughts ?

I thought this was what we agreed to do all along. Did something
change? I think we made a comment that if we can progress in the m1
branch further we can maybe merge again but that's only if it's
stable.

The felix stuff is not very stable right now. It's very odd in
behavior so I'm not going to be comfortable with a merge for a while.
All these additional cache directories and file locking makes the
concurrent tests all fickle. I don't want Hudson freaking out with
false positives either.

Regards,
Alex

Mime
View raw message