directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: Strange errors when running tests in eclipse
Date Fri, 14 Jan 2011 08:33:13 GMT
Hi Emmanuel,

On Wed, Jan 12, 2011 at 8:13 PM, Emmanuel Lecharny <elecharny@gmail.com> wrote:
> it's now a few weeks I get a painful and unexpected error when launching a
> test after having done a svn up followed by a refresh in eclipse. I'm
> launching a test in core integ, and the test not even starts, throwing an
> exception :
>
> java.io.FileNotFoundException: ERR_10004 Expecting to find a schema.ldif
> file in provided baseDirectory path
>
> I understand that it's a problem about the missing ou=schema.ldif file, and
> if I rebuild the full server, then the file is created and present.
>
> Is there something changed recently around the schema exctraction ?

Yes, we changed the schema extraction code so that it works in OSGi
environments (Studio).

During the maven build, in the generate-resources phase, the
ldap-schema/target/classes/META-INF/apacheds-schema.index file is
created. This index file is then used by the
DefaultSchemaLdifExtractor to find and copy the schema files.

If you refresh and rebuild the Eclipse workspace the the
target/classes folder is deleted. The Eclipse build don't generate the
index file. Then the schema extractor won't copy any schema file to
the target location.

What we can try is to create the index file in
target/generated-sources which is also done by other maven plugins
(e.g. antlr). Those target folders survive a refresh of the Eclipse
workspace.

Kind Regards,
Stefan

Mime
View raw message