directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <akaras...@apache.org>
Subject Re: Writing a specific Authenticator, and add some configuration for iy
Date Mon, 06 Dec 2010 16:12:45 GMT
Thanks Antoine.

On Mon, Dec 6, 2010 at 6:03 PM, Antoine Levy-Lambert <antoine@gmx.de> wrote:

>  Hello Alex,
>
>
> On 12/6/2010 10:26 AM, Alex Karasulu wrote:
>
>
>
> On Mon, Dec 6, 2010 at 3:54 PM, Antoine Levy-Lambert <antoine@gmx.de>wrote:
>
>>  On 12/5/2010 12:03 AM, Alex Karasulu wrote:
>>
>> Antoine,
>>
>> On Fri, Dec 3, 2010 at 12:42 AM, Alex Karasulu <akarasulu@apache.org>wrote:
>>
>>>  On Thu, Dec 2, 2010 at 4:31 PM, Antoine Levy-Lambert <antoine@gmx.de>wrote:
>>>
>>>>  At this stage I would like to merge the branch antoine back to trunk.
>>>>
>>>>
>>>  OK I'll try to take a look at this tomorrow.
>>>
>>>
>>
>>  OK I tried to build your branch but there we some failures in some
>> tests. Have you committed everything into your branch and tried building
>> without -DskipTests=true ?
>>
>>  Hello Alex,
>>
>> yes, I committed everything in my branch. No, I did not rebuild everything
>> with -DskipTests=true. Which tests were failing ? Is the breakage caused by
>> my changes ?
>>
>
>  I guess you added some more schema entities and some tests which count
> schema entities like OCs and ATs bombed. Not a big deal and I fixed there
> here in this commit:
>
>      http://svn.apache.org/viewvc?view=revision&revision=1042669
>
> Thanks
>
>
>  But this worried me a little that you might not have checked in this fix
> since it's rather simple. Maybe you did not have a chance to run all the
> test cases and integr
> org.apache.directory.server.core.suites.StockCoreISuiteation tests.
>
> I ran StockServerISuite, but not StockCoreISuite. Will do it.
>
>
>  After this fix though other tests started to fail down stream. One of the
> integration tests just seems to hang for example:
>
>
>  org.apache.directory.server.core.partition.SingleFileLdifPartitionTest
>
> I will look into that.
>
>
>
>  Wondering if you successfully ran the integration tests on your machine
> or if this is something due to my very own environment. Note that this was
> not the case when I created the branch. I ran all tests to make sure you had
> a clean setup. However this test was done on a mac and now I'm on a Linux
> box so it can still be me. But regardless the tests with failed schema
> entity counts should have failed for you when you ran the tests.
>
> No, it is not due to your environment. Because some of the tests were
> failing for me in the previous days I did not run all the tests. I will do
> it.
>
>
>  BTW my environment:
>
>  akarasulu@stein:~$ mvn -version
> Apache Maven 3.0.1 (r1038046; 2010-11-23 12:58:32+0200)
> Java version: 1.6.0_22
> Java home: /usr/lib/jvm/java-6-sun-1.6.0.22/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux" version: "2.6.35-23-generic" arch: "amd64" Family: "unix"
>
>  Best,
>  --
>  Alex Karasulu
> My Blog :: http://www.jroller.com/akarasulu/
> Apache Directory Server :: http://directory.apache.org
> Apache MINA :: http://mina.apache.org
> To set up a meeting with me: http://tungle.me/AlexKarasulu
>
> Regards,
>
> Antoine
>



-- 
Alex Karasulu
My Blog :: http://www.jroller.com/akarasulu/
Apache Directory Server :: http://directory.apache.org
Apache MINA :: http://mina.apache.org
To set up a meeting with me: http://tungle.me/AlexKarasulu

Mime
View raw message