directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hammond, Steven" <Steven.Hamm...@Polycom.com>
Subject RE: Example of embedding ApacheDS in 2.0?
Date Fri, 05 Nov 2010 04:22:26 GMT
I got past the Ldifs issue in DefaultSchemaLdifExtractor.  I had a Context.java.diff file in
my lib directory and eclipse java build path, and that was causing extract to barf.
Now it is getting thru loading the standard set of Ldifs, and I need to find a way to import
the sets I was using before.  H.350 and some custom attributes I have been using in 5.3
And it got much further.  I will try more in the morning.


-----Original Message-----
From: Emmanuel Lecharny [mailto:elecharny@gmail.com] 
Sent: Thursday, November 04, 2010 5:56 PM
To: Apache Directory Developers List
Subject: Re: Example of embedding ApacheDS in 2.0?

On 11/4/10 8:31 PM, Hammond, Steven wrote:
> I am trying to utilize up to the minute, bleeding edge ApacheDS server.  Since I am moving
from 1.5.3, lots of stuff is new.  I have tried to use some docs I found and the docs I built
with doc book, but I have not found an example that works with the head of trunk.

Couragous !

if you really took everything on the trunk, you must know that we just 
merged last saturday a whole bunch of modifications done in the 
configuration, which have somehow broke some things that we since have 
fixed.

At least, tests are passing on trunk, and the server launched from 
UberMain.java is running too, so we know that's trunk is viable.

> What I have does not work yet, I am still trying different things, but not getting a
server running yet.
>
> This is what I have.  The first time I run it, it tries to extract the Ldifs from my
build/classes directory, where there are no ldifs.
Which ldifs exactly ?

>   Any time after that I try to run, it says directory exists and throws.

Ok. I have to try your start program, but I will probably do that only 
tomorrow, in the afternoon (Paris time).

Note that the new server is totally based on configuration in DIT, and 
you will have to tune the config.ldif file.

Let's try to figure out what's going in your case, because we anyway 
will need to get it working !!

Thanks for the feedback.


-- 
Regards,
Cordialement,
Emmanuel L├ęcharny
www.iktek.com


Mime
View raw message