directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: Switch to Maven 3.0 for next ADS release?
Date Tue, 09 Nov 2010 12:20:31 GMT
On 11/9/10 10:56 AM, Felix Knecht wrote:
> Shall we switch to Maven 3.0 for next release of ADS?
I'm already using maven 3 since it got out. No problem so far
> Maven 3 is not fully backwards compatible with Maven 2 [1].
I have fixed many warnings. We may go a bit further.
> ADS/Shared build/test work for me using Maven 3, site generation (not 
> very surprisingly) doesn't. Studio build doesn't works for me, the 
> eclipse artifacts are not found.
I think we can wait until Maven 3 is fully supporting Eclipse build.
>
> IMO it makes only sense to switch to Maven 3 when it is also available 
> on the CI-servers.
Absolutely. In the mean time, everyone can use maven 3, but we must 
check that the build still works with Maven 2.2.1


-- 
Regards,
Cordialement,
Emmanuel L├ęcharny
www.iktek.com


Mime
View raw message