Gentlemen,

I've been exploring and working my way through getting the Subversion checkout and Maven builds working reliably so that I'm comfortable with that process.  I've been working on two different systems (I have a day job).

My home system is Fedora Core 13 Linux with the Sun JDK 1.6_20, Subversion, Maven 2.2.1, and Eclipse 3.6 installed.  On this system I had little trouble following the steps suggested:

1)        Checkout trunk-with-dependencies
2)        "mvn clean install -DskipTests"
3)        "mvn eclipse:eclipse"

I was able to import that projects into Eclipse without difficulty after the above steps.

Back at a command prompt I tried running the following to make sure everything was working.

4)        "mvn test"

Only one test "testSaslGssapiBind" is failing, and, looking at the test code, it appears that the author doesn't expect this one to work yet.


At my day job I have a Windows XP SP-3 with Sun JDK 1.6_17, Maven 2.2.1, Subversion, and Eclipse 3.6 installed.

Access to the Internet from this system is restricted to using an HTTP proxy that requires NTLM authentication.  I've had a bit of a struggle getting Maven and Subversion working through this but finally seem to have it (except for m2Eclipse which still seems unable to access anything through the proxy).  I have noticed though that the proxy is either overloaded or just plain unreliable.  I did finally succeed in getting a clean checkout, however.

Again the same three steps mentioned above were completed successfully (despite the erratic operation of the proxy server).

When I tried "mvn test", however, I got several failures.

One of the failures, "testSaslGssapiBind", is the same as on Linux.  For now I'm assuming this is a known problem that is being worked on.

Using Eclipse to investigate each of the others I've discovered that two of them are related to Windows's use of the "\" character as the path separator and one is related to incorrect handling of "escaping" of characters in filenames.  I'm developing fixes for these issues now and will post suggested patches after I complete testing.

The only remaining test failure, is "testSearchUTF8" in "ClientSearchRequestTest" which is not throwing the expected Exception.  I haven't investigated this one yet but plan to when time is available.

Thanks for the guidance.

Richard Feezel


. This is an e-mail from General Dynamics Land Systems. It is for the intended recipient only and may contain confidential and privileged information. No one else may read, print, store, copy, forward or act in reliance on it or its attachments. If you are not the intended recipient, please return this message to the sender and delete the message and any attachments from your computer. Your cooperation is appreciated.