directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin, Roy" <rbenja...@ebay.com>
Subject RE: Startup Error for Embedded ApacheDS Created by ApacheDS archetype
Date Tue, 03 Aug 2010 00:34:04 GMT
Hi,

You bet, I have to deal with a large corporate environment; it made maven
difficult to deal with.  Most developers work within the approved jar framework
and never hot an external repository at all.  I actually had to remove my local
repository, settings, xml, etc.. and start over.

I can't seem to get IRC working, not sure what's wrong but unable to contact any
servers.  I think possibly it's blocked.

I was initially very encouraged because there are several examples for embedded
server.  Well documented on an HTML page and all.  After I got them built I've
not been able to run them.   Actually, one of them runs unless I try to add an
Authenticator.  The others fail to run for various reasons related files and
configuration I guess.  There is also a standalone example, I can't tell if it's
working or not because it's impossible to discover what port it's using; not
a known or standard one I guess.  There also doesn't seem to be any API to set
the port before starting the server.

Some of the embedded examples are documented as working with a previous version,
so I've finally got four different versions built and should be able to get an
example working.  I'm a reasonably competent maven user but no expert for sure,
the maven versioning within each of these source trees seems really inconsistent 
though.  Still I can build, and start an embedded server, it's just not possible
to programmatically add an Authenticator I guess.  I wouldn't have worked on this
as long as I have except that I don't have a viable 'Plan B' right now.  I really
do appreciate the open source community; it's about the only source for quality
software now days.  In this case it's been more frustrating than I had possibly
imagined.

Thanks!
Roy



-----Original Message-----
From: Emmanuel Lecharny [mailto:elecharny@gmail.com] 
Sent: Monday, August 02, 2010 5:14 PM
To: Apache Directory Developers List
Subject: Re: Startup Error for Embedded ApacheDS Created by apacheds archetype

  On 8/2/10 11:16 PM, Benjamin, Roy wrote:
> Thank Kiran,
>
> Still not working but I'll keep trying for a while.   I've been working for ten days
> now trying to get at least one of the provided embedded examples working.   I appreciate
> all the work contributors do but I must say in thirty years I've never had this much
> trouble getting an Apache example to work.

Yeah, but you must admit that many of the problem you faced so far 
weren't ADS related (I'm thinking about Maven issues you had, for instance.)

Plus this is not simply as if you were installing ADS alone : you are 
trying to embed it in a tomcat server, with all the classloaders problem 
and file protections that come with ...

May I suggest you move forward step by step instead of tying all together ?

PS : I very much understand your feeling, btw. I too am a old fart who 
fumes when testing an open source program and don't succeed after a few 
steps... yuk, that's life ! :)

Btw, if you need more interactive directions, try to join us on IRC 
(#apache-directory).

-- 
Regards,
Cordialement,
Emmanuel L├ęcharny
www.iktek.com


Mime
View raw message