directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@gmail.com>
Subject Re: Message data structure merge heads up
Date Thu, 12 Aug 2010 14:51:49 GMT
  On 8/12/10 4:24 PM, feezelr@gdls.com wrote:
> Gentlemen,
Hi,
> My home system is Fedora Core 13 Linux with the Sun JDK 1.6_20,
> Subversion, Maven 2.2.1, and Eclipse 3.6 installed.
Perfect.
> Back at a command prompt I tried running the following to make sure
> everything was working.
>
> 4)      "mvn test"
>
> Only one test "testSaslGssapiBind" is failing, and, looking at the test
> code, it appears that the author doesn't expect this one to work yet.
Strange. All the tests are passing on our linux machines.

Have you tried mvn clean install -Dintegration ?
> At my day job I have a Windows XP SP-3 with Sun JDK 1.6_17, Maven 2.2.1,
> Subversion, and Eclipse 3.6 installed.
>
> Access to the Internet from this system is restricted to using an HTTP
> proxy that requires NTLM authentication.
Thanks a lot, M$ ...

<snip/>
> Again the same three steps mentioned above were completed successfully
> (despite the erratic operation of the proxy server).
>
> When I tried "mvn test", however, I got several failures.
>
> One of the failures, "testSaslGssapiBind", is the same as on Linux.  For
> now I'm assuming this is a known problem that is being worked on.
>
> Using Eclipse to investigate each of the others I've discovered that two
> of them are related to Windows's use of the "\" character as the path
> separator and one is related to incorrect handling of "escaping" of
> characters in filenames.  I'm developing fixes for these issues now and
> will post suggested patches after I complete testing.
Great ! We don't use W$ at all, so it's likely we have some tests 
failure if we are not cautious enough. That's the price to pay for being 
efficient...

> The only remaining test failure, is "testSearchUTF8" in
> "ClientSearchRequestTest" which is not throwing the expected Exception.  I
> haven't investigated this one yet but plan to when time is available.

Hmmmm... I don't find this class. In which module did you found it ?



-- 
Regards,
Cordialement,
Emmanuel L├ęcharny
www.iktek.com


Mime
View raw message