directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [ApacheDS] Bad Dependency on commons-net 2.1
Date Sat, 17 Jul 2010 20:12:12 GMT
I just checked that release 1.5.7 uses commons-net 2.0 and the upgrade
to commons-net 2.1 was done after the 1.5.7 release in commit 937229
[1] and 937269 [2], so the 1.5.7 release is ok.

Kind Regards,
Stefan

[1] http://svn.apache.org/viewvc?view=revision&revision=937229
[2] http://svn.apache.org/viewvc?view=revision&revision=937269

On Sat, Jul 17, 2010 at 9:50 PM, Stefan Bodewig <bodewig@apache.org> wrote:
> Hi,
>
> the Apache Commons PMC realized about two weeks ago that the mvn repo
> contains artifacts for commons-net 2.1 which has never been released and
> subsequently removed those from central.  The next commons-net version
> is likely going to be 2.2 (and will probably use the org.apache.commons
> groupId instead of commons-net).
>
> While looking into a Gump build failure (<http://gump.apache.org/> has
> silently been building much of the directory project for a few months) I
> saw that ApacheDS depends on 2.1
> <http://svn.apache.org/repos/asf/directory/apacheds/trunk/pom.xml> which
> means clean builds no longer work ('cause 2.1 is nowehere to be found
> anymore).
>
> Gump used to build ApacheDS against the 1.x branch of commons-net so I
> think you could safely dpwngrade to commons-net 2.0 until 2.2 has been
> released.
>
> Cheers
>
>        Stefan
>

Mime
View raw message