directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [Studio] Compilation failures in integration tests
Date Mon, 07 Dec 2009 19:05:41 GMT
Hi Pierre-Arnaud,

Pierre-Arnaud Marcelot schrieb:
> Hi,
> 
> I'm having compilation failures in integration tests.
> 
> In the *'test-integration-core' module*:
...
I'd suggest to remove test-integration-core. It only contains some few 
connection test, not more. Those test cases are fully covered by the 
connection tests of the test-integratoin-ui module. I think it isn't 
worth to maintain this module.


> In the *'test-integration-ui' module*:
> ...
>     cannot access org.eclipse.core.runtime.jobs.Job
>     class file for org.eclipse.core.runtime.jobs.Job not found
>             StudioConnectionJob job = new StudioConnectionJob( new
>     OpenConnectionsRunnable( connection ) );

I added org.eclipse.core:jobs dependency.

>     /home/pajbam/Development/Apache/Studio/test-integration-ui/src/main/java/org/apache/directory/studio/test/integration/ui/bots/EntryEditorWidgetBot.java:[61,18]
>     cannot find symbol
>     symbol  : method
>     pressShortcut(org.eclipse.jface.bindings.keys.KeyStroke)
>     location: class org.eclipse.swtbot.swt.finder.widgets.SWTBotTree

In my eclipse installation I have e newer version of SWTBot than the 
provided in "resources/test-plugins". The update site has more recent 
versions. I'll try to fetch the newest version and I hope it will build 
then. Stay tuned...

> Stefan, do you have a clue what I'm doing wrong?

Nothing, I just was to lazy to maintain the modules, sorry.

Kind Regards,
Stefan


Mime
View raw message