Sorry for not opining on this thread.  However I don't like to look back into the past and it makes sense to me to move to Java 6 since 5 has reached EOL.  However if people feel strongly about coming out with Java 5 then I will yield to their needs before mine. 

We can move to Java 6 with versions to follow.

Regards,
Alex

--
Alex Karasulu
My Blog :: http://www.jroller.com/akarasulu/
Apache Directory Server :: http://directory.apache.org
Apache MINA :: http://mina.apache.org