Done!

This is fixed... :)

Regards,
Pierre-Arnaud

On Tue, Oct 6, 2009 at 11:50 AM, Pierre-Arnaud Marcelot <pa@marcelot.net> wrote:
Indeed,

I'll try to exclude it but we'll need to not forget to remove this before the release.

Regards,
Pierre-Arnaud 


On Tue, Oct 6, 2009 at 11:27 AM, Stefan Seelmann <seelmann@apache.org> wrote:
Pierre-Arnaud Marcelot wrote:
> Actually I removed the "-SNASHOT" on purpose... I should have included a
> small explanation comment here.
>
> Let me explain.
>
> The Apache Launcher project version needs to be set to a non "-SNAPSHOT"
> version because it is used in the Apache DS plugin and it is referenced
> as a string with its version hard-coded in a class as a jar dependency
> for launching Apache DS.
>
> If we set the value to a "-SNAPSHOT" value, then when we release the
> 1.5.0 version, the Apache DS plugn won't be able to start Apache DS,
> because it would reference the "-SNAPSHOT" version in the class.
>
> It's a little bit tricky and dirty, but it's the only solution I have
> for now.
>
Ok, thanks.

I added the "-SNAPSHOT" to make Continuum happy, as it tried to upload a
 non-snapshot jar to the snapshot repository and failed. So maybe we
should exclude apacheds-launcher from deployment?

Kind Regards,
Stefan