directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: [VOTE] Release of Apache Directory Studio 1.5
Date Sat, 24 Oct 2009 09:50:10 GMT
Hi Emmanuel,

Emmanuel Lecharny wrote:
> Some few issues I have :
> - when opening the Schema Borwoser with an OpenLDAP server, I can only
> see the AT and Syntax, nothing else.

I can see all schema object (OC, AT, MR, MRU, Syntax). I'm using
OpenLDAP 2.4.15 on my Ubuntu box. I'll test with other OpenLDAP versions
as well.

What happens if you reload the schema in the schema browser?

> Also, if I right click on the cn=Subschema entry, and check the "Include
> the operational atttributes' box, and click on 'Refresh', I get an LDAP
> error 32: No such Object message. However, this is the only way to see
> all the SchemaObjects (and it works).

First, if you toggle the checkbox there should be an automatic refresh.

Second, the error message occurs, that is right. The reason is that the
'Refresh' action in the 'LDAP Browser' view does two searches:
- a scope=base search for the entry to load all its attributes
- a scope=one search for the entry to load all its children

OpenLDAP returns such an error for the latter search. BTW, this error
exists since day one of studio ;-)

> When the entry is opened, if I right click on the AT, and select 'Show
> in Ldap Browser', nothing happens.

This action selects the entry that is opened in the entry editor in the
LDAP Browser. This could make sense if the "Link with Editor" action is
off. Of course, if the entry is already selected in the LDAP Browser
than nothing happens.

However I found another issue with that feature. The label of the
selected entry in the LDAP Browser changes to "-1, filtered". I'll
investigate...

> The very same, if I right click on AT and select 'show in Ldap browser',
> and then right click on ObjectClasses, the 'Open Schema Browser' menu is
> all disabled.

Yes, I could confirm this bug.

> Seems like a bit unstable at this point...

Thanks for testing!

Kind Regards,
Stefan


Mime
View raw message