directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "yakup korkmaz (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSERVER-1408) can not start Apache Directory Server as service
Date Fri, 04 Sep 2009 14:08:57 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-1408?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12751470#action_12751470
] 

yakup korkmaz commented on DIRSERVER-1408:
------------------------------------------

You are right, it worked that way. I mean, i downloaded the Apacheds zip file, extract it
and start the .bat file. Then checked the .log file, there were just 2 warning messages same
as the log message above, but this time there were no error and exception messages, it means,
it is started.

Actually, i first installed Apache Directory Suite and created a server inside it. But server,
which was actually apacheDS, could not be started, after having this problem i installed the
apacheDS as a standalone application to check. Then i realised it could not be started also
a windows service. It was why i started a thread here.

So, is it possible to have the not the embedded apacheds but the one i extracted from zip
file, working as a ldap server in apache directory suite? or is it possible to use other servers
like openLDAP as a ldap server for the apache directory suite?

> can not start Apache Directory Server as service
> ------------------------------------------------
>
>                 Key: DIRSERVER-1408
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1408
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 1.5.5
>         Environment: Microsoft XP and also Vista Home Premium
>            Reporter: yakup korkmaz
>            Priority: Critical
>
> Hi community,
> I installed the Apache Directory Server 1.5.5, but after the installation i can not start
the ApacheDS as a service in Windows. Below you can find the error message from the wrapper.log;
> ERROR [org.apache.directory.daemon.Bootstrapper] - Failed on null.init(InstallationLayout,
String[])
> INFO   | jvm 1    | 2009/09/03 09:43:43 | org.springframework.beans.factory.BeanCreationException:
Error creating bean with name 'directoryService' defined in URL [file:/C:/Program%20Files/Apache%20Directory%20Server/instances/default/conf/server.xml]:
Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException:
Could not instantiate bean class [org.apache.directory.server.core.DefaultDirectoryService]:
Constructor threw exception; nested exception is java.lang.IllegalStateException: Something
has got to be severely wrong with the core packaging
> INFO   | jvm 1    |
>  2009/09/03 09:43:43 | or the build to have resulted in this exception.
> i have no idea what causes this exception but i tried to install it to another computer
and got the same error message. My OS is Xp and other computer's is Vista, but i couldnot
start it in both computers. But interesting thing is, i didn't see anything about it in forums,
am i the first one having this problem or do i miss something?
> thanks,
> Yakup

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message