directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Beat Burgener (JIRA)" <j...@apache.org>
Subject [jira] Created: (DIRSERVER-1409) Buffer underrun while connecting to Apache DS
Date Thu, 17 Sep 2009 09:02:57 GMT
Buffer underrun while connecting to Apache DS
---------------------------------------------

                 Key: DIRSERVER-1409
                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1409
             Project: Directory ApacheDS
          Issue Type: Bug
          Components: core
    Affects Versions: 1.0.2
         Environment: chrooted environment, Slackware 12.1.0 (32bit), JRE 1.5.0_19, tighten
file permissions
            Reporter: Beat Burgener


ApacheDS run's well for some time, but suddenly does not allow new connections!
Connecting via telnet does open the connection, but that's it.
Apache Studio does start initiating the connection, but cannot establish one.
The following is logged:

[08:49:53] DEBUG [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler]
- [/192.168.255.31:4709]  doHandshake()
[08:49:53] DEBUG [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler]
- [/192.168.255.31:4709]   initialHandshakeStatus=NEED_UNWRAP
[08:49:53] DEBUG [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler]
- [/192.168.255.31:4709]  unwrapHandshake()
[08:49:53] DEBUG [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler]
- [/192.168.255.31:4709]    inNetBuffer: java.nio.DirectByteBuffer[pos=0 lim=0 cap=16665]
[08:49:53] DEBUG [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler]
- [/192.168.255.31:4709]    appBuffer: java.nio.DirectByteBuffer[pos=0 lim=33330 cap=33330]
[08:49:53] DEBUG [org.apache.directory.server.ldap.LdapProtocolProvider$LdapProtocolHandler]
- [/192.168.255.31:4709]  Unwrap res:Status = BUFFER_UNDERFLOW HandshakeStatus = NEED_UNWRAP
bytesConsumed = 0 bytesProduced = 0


Well, as said, this is running in chroot, where Apache DS is started as root, but not run
as root.
Further, limited libraries, devices are available.

As it works fine for some time, I do not really assume this to be an issue ...
But this is the target configuration, so I have to get it to work like this ...

If I can assist in any way, please do not hesitate to contact me

Thank you

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message