directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "yakup korkmaz (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DIRSERVER-1408) can not start Apache Directory Server as service
Date Thu, 03 Sep 2009 09:26:32 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-1408?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12750932#action_12750932
] 

yakup korkmaz commented on DIRSERVER-1408:
------------------------------------------

actually i installed only latest version, i did not have any other apacheds installed in my
computer. i am not sure if it is because our office's security configurations but i tried
it in two different computers here in the office and i got the same error.

i installed also the latest jre which is java 6 update 16, but still have the same problem.
Below is the related entries with the problem in apacheds.conf, is everything ok with them,
may be there are some configuration changes needed to be applied?

# Application parameters.  Add parameters as needed starting from 1
wrapper.app.parameter.1="%APACHEDS_HOME%"
wrapper.app.parameter.2=org.apache.directory.server.Service
wrapper.app.parameter.3="%INSTANCE_HOME%/%INSTANCE%/conf/server.xml"

i have no clue and found also nothing in internet, i think i am the only one experiencing
this problem:)? any help or suggestion will be appreciated,

thanks

> can not start Apache Directory Server as service
> ------------------------------------------------
>
>                 Key: DIRSERVER-1408
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1408
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 1.5.5
>         Environment: Microsoft XP and also Vista Home Premium
>            Reporter: yakup korkmaz
>            Priority: Critical
>
> Hi community,
> I installed the Apache Directory Server 1.5.5, but after the installation i can not start
the ApacheDS as a service in Windows. Below you can find the error message from the wrapper.log;
> ERROR [org.apache.directory.daemon.Bootstrapper] - Failed on null.init(InstallationLayout,
String[])
> INFO   | jvm 1    | 2009/09/03 09:43:43 | org.springframework.beans.factory.BeanCreationException:
Error creating bean with name 'directoryService' defined in URL [file:/C:/Program%20Files/Apache%20Directory%20Server/instances/default/conf/server.xml]:
Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException:
Could not instantiate bean class [org.apache.directory.server.core.DefaultDirectoryService]:
Constructor threw exception; nested exception is java.lang.IllegalStateException: Something
has got to be severely wrong with the core packaging
> INFO   | jvm 1    |
>  2009/09/03 09:43:43 | or the build to have resulted in this exception.
> i have no idea what causes this exception but i tried to install it to another computer
and got the same error message. My OS is Xp and other computer's is Vista, but i couldnot
start it in both computers. But interesting thing is, i didn't see anything about it in forums,
am i the first one having this problem or do i miss something?
> thanks,
> Yakup

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message