Ahh ok you're right I did not consider the confusion with alias entries that could result.
+1. I think that sticking to the RFC names eliminate the confusion. Aliases are something different in LDAP terminology. In this very case, the RFC call those NAME aliases, but the Description uses NAME, not ALIAS.Stefan Seelmann wrote:
Alex Karasulu wrote:
>From RFC 4512:
The NAME field provides a set of short names (descriptors) that are
to be used as aliases for the OID.
So there are at least three synonyms for the same thing.
I'd use the terms defined in the ABNF and that is 'NAME'. Otherwise also
many other methods could be renamed (e.g. getMayAttributeTypes could be
named getAllowedAttributeTypes or getOptionalAttributeTypes).
My 2 cents,