directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <akaras...@gmail.com>
Subject Re: [Shared] [Schema API] Shouldn't getName[s] really be getAliases[s]
Date Sun, 30 Aug 2009 19:41:41 GMT
Ahh ok you're right I did not consider the confusion with alias entries that
could result.

On Sun, Aug 30, 2009 at 10:22 PM, Emmanuel Lecharny <elecharny@apache.org>wrote:

> Stefan Seelmann wrote:
>
>> Alex Karasulu wrote:
>>
>>
>>> Thoughts?
>>>
>>>
>>
>> >From RFC 4512:
>>   The NAME field provides a set of short names (descriptors) that are
>>   to be used as aliases for the OID.
>>
>> So there are at least three synonyms for the same thing.
>>
>> I'd use the terms defined in the ABNF and that is 'NAME'. Otherwise also
>> many other methods could be renamed (e.g. getMayAttributeTypes could be
>> named getAllowedAttributeTypes or getOptionalAttributeTypes).
>>
>>
> +1. I think that sticking to the RFC names eliminate the confusion. Aliases
> are something different in LDAP terminology. In this very case, the RFC call
> those NAME aliases, but the Description uses NAME, not ALIAS.
>
>> My 2 cents,
>> Stefan
>>
>>
>>
>>
>>
>
>
> --
> --
> cordialement, regards,
> Emmanuel L├ęcharny
> www.iktek.com
> directory.apache.org
>
>
>


-- 
Alex Karasulu
My Blog :: http://www.jroller.com/akarasulu/
Apache Directory Server :: http://directory.apache.org
Apache MINA :: http://mina.apache.org

Mime
View raw message