directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Arnaud Marcelot ...@marcelot.net>
Subject Re: [Schema refactoring] Should we rename XXXDescription to xxxSpecification ?
Date Mon, 24 Aug 2009 15:13:35 GMT
Hi Emmanuel,
As the RFC4512 uses the terms 'AttributeTypeDescription',
'ObjectClassDescription', etc.

I think it'd be better to stick the RFC's naming conventions.

My 2 cents,
P-A

On Mon, Aug 24, 2009 at 4:32 PM, Emmanuel Lecharny <elecharny@apache.org>wrote:

> Hi,
>
> we have two classes of object for each SchemaObject :
> - AttributeType and AttributeTypeDescription
> ...
> - Normalizer and NormalizerDescription
>
> The second class is used to hold the OpenLDAP/RFC description for the
> manipulated SchemaObject. For the AttributeType, the description looks like
> :
>
> ( 2.5.4.9 NAME ( 'street' 'streetAddress' )
>   DESC 'RFC2256: street address of this object'
>   EQUALITY caseIgnoreMatch
>   SUBSTR caseIgnoreSubstringsMatch
>   SYNTAX 1.3.6.1.4.1.1466.115.121.1.15{128} )
>
> but for the AttributeType, the description field contains the DESC value :
>  'RFC2256: street address of this object'
>
> I suggest that the second class is  renamed AttributeTypeSpecification.
>
> Thoughts ?
>
> --
> --
> cordialement, regards,
> Emmanuel L├ęcharny
> www.iktek.com
> directory.apache.org
>
>
>

Mime
View raw message